MTRLib α版 – Sassで未対応ブラウザへのCSS3使用は警告&自動修正!
はてなブックマーク - MTRLib α版 – Sassで未対応ブラウザへのCSS3使用は警告&自動修正!
Pocket

ライブラリの制作の方法については、以前のエントリである「Sassで未対応ブラウザへのCSS3使用は警告&自動修正!」を参考にしてください。今回は、紹介しているトピックスをまとめたものをライブラリとして公開する旨のエントリーとなります。こんな感じでライブラリ作ってますよ!と言いたいだけなので、まだまだ完成とは言えるものではありません。

 

 
 

何ができるのか

予め対応予定のブラウザを設定してください。すると勝手に CSS3 に対応していない場合は警告を出します。中には自動で IE に対応するものもあります。なので CSS3 のブラウザ対応表とにらめっこする必要がありません。

導入方法

こちらでダウンロード後、普段使用している Sass のファイルがあるフォルダ内にコピー後、「 _mtrlib.scss 」をインポートしてください。それだけです。

 

まだ Sass 自体をインストールしていない場合は、「Sass導入 – Windows7 + Sass」を参考にしてみてください。

 

 
 

使い方

CSS3 を直に書いている場合は、以下のようなソースになっているかと思います。

これを以下に書き換えてください。

このように CSS3 のプロパティを書き換えます。これだけで勝手にベンダープレフィックスを出力する上、未対応ブラウザに対しては警告を出します。

 
 

パラメータの設定

対応ブラウザ

対応予定のブラウザを設定します。「 _exparam.scss 」ファイルを開いてください。以下の変数が定義されていると思います。

これを以下に書き換えてください。

すると、当ライブラリを使用している CSS3 のプロパティで、 IE8 に対応していないものがあればコンパイル時に警告を出します。中には自動で IE 用に変換されるものもあります。その場合も変換したことを警告で知らせてくれます。

 

 

使用するベンダープレフィックス

「 _exparam.scss 」ファイルを開いてください。以下の変数を定義します。

すると、「 -webkit- 」を使用しません。対応不要なベンダープレフィックスの出力を行わないよう設定することができます。

 

他にもいくつかパラメータがありますが、もう少しライブラリの完成が近づいたらドキュメントでも作ろうかと思ってます。(使う方がいればの話ですが)

 
 

現在作成しているプロパティ

作っているプロパティの一覧です。もし、こんなのを作って欲しいなどありましたら是非 Twitter にて連絡を頂ければと思います。

RGBA

HSLA

border-radius

box-shadow

opacity

transition

 
 

ライセンス

MIT License

github

2012年9月27日追記
 
Twitter にて有難くご指摘をいただきましたので、 github にて公開致しました。